Flutter版本管理工具

2020-11-27

在使用Flutter开发过程中,我们经常会遇到需要切换版本的时候,而且flutter切换channel后需要重新下载大量内容,每个channel切换完成后需要再跑flutter doctor,又会有大量的下载,而且还都是国外服务器,下载非常慢。

于是尝试着寻找一款合适的工具,原则是可以跨平台,最好是Golang开发的,很巧的是发现 https://blog.befovy.com/2019/12/fvm-using-go/ 这位Golang博主已经开发完成了,github链接在此,主要的思路与使用Dart编写的fvm异曲同工。

安装

由于我是使用Mac电脑的,所以直接使用brew安装

brew tap befovy/taps
brew install fvm

fvm支持导入已有的SDK,由于我之前安装的是stable的channel,所以使用如下命令:

fvm import stable

等待几分钟后即可全部导入完成。

环境变量配置

在使用fvm之前,实际上我已经手动安装过Flutter,所以需要重新修改下环境变量地址,fvm的默认安装路径如下:

export FLUTTER_PATH=~/Library/Application\ Support/fvm/current
export PATH=$PATH:$FLUTTER_PATH/bin

需要根据自己的电脑终端情况,把上述代码拷贝到.bash_profile或者.zshrc文件。

安装指定版本

如果之前未安装其他版本,需要先安装,例如我安装“1.17.5”版本:

fvm install 1.17.5
# 或者
fvm install 1.17.5 --repo https://mirrors.tuna.tsinghua.edu.cn/git/flutter-sdk.git

上述带--repo表示指定路径,推荐使用国内清华镜像加速下载,不过我在实际使用中出现过下列问题:

fvm: Command 'git' exited with error: chdir ~/Library/Application Support/fvm/versions/1.17.5: no such file or directory

结果去掉--repo就正常下载了,如果遇到类似的问题,可以带和不带--repo都试下,我遇到的就是不带是OK的。

使用指定版本

安装好指定版本以后,可以直接使用use命令来使用:

fvm use 1.17.4
flutter doctor

无回应:“Flutter版本管理工具”

发表评论

电子邮件地址不会被公开。 必填项已用*标注